Compatibility Dependency – Eye Adaptation Complete Overhaul

Modders Resources






You only want Compatibility Dependency of



Eye Adaptation Complete Overhaul



if another mod you want to install relies on it to create EACO-enabled experience.


So, you should only get this if another mod’s author mentioned and required that you also download one of the main files from this mod to get full benefit of Eye Adaptation Complete Overhaul.

Otherwise, you’re much better suited downloading my original, standalone Eye Adaptation Complete Overhaul. You can find links to those right below, within the

light blue font paragraph

.


If you are a mod author interested in creating a compatible mod, scroll all the way down for instructions.

















If you wish to support me:

I also run an incredibly successful gaming

YouTube


channel

.

MILLIONS of people tune in every day! You can, too – just watch this video.

Thank you so much!








“I was blind, and now I can see!”




~~ John 9:25




This is the



Compatibility Dependency



for my Eye Adaptation Complete Overhaul, which you may have seen before as


Vanilla Weather


variant or


Diverse Weather


variant.


Meanwhile, this Compatibility Dependency world-editing component will not affect your weather at all! That is left fully under control of any mod its complementing.



My EACO mod edits a lot of files but the most common conflict is because of





cp2077_master_env_nge_v002.env

which controls things like weather patterns, eye adaptation, forced sharpening, permanent vignette, sky settings including moon, etc.







Thanks to Compatibility Dependency, other mod authors can use their favorite variant of my Eye Adaptation Complete Overhaul as a baseline for their mod, and you  need to download the Compatibility Dependency from this page to get the world-editing component of my mod.



















If you are a mod author interested in creating a compatible mod, scroll all the way down for instructions.











If you need any more information about what is Eye Adaptation Complete Overhaul, click on one of the hyper links above.

Extreme TL;DR:



I came back to finish the job that I started in April 2021. It’s time for the Badlands auto exposure to calm the !@#$ down. And many other places, actually, because there’s OH, SO MANY configs that I found and tweaked. Based on my current knowledge, in fact, I believe that I tweaked every single case of auto exposure in the entire game.









Installation instructions





Needless to say, you probably don’t want to use multiple different mods that all rely on Eye Adaptation Complete Overhaul, as using multiple will just create a conflict and usually won’t grant you any benefit or extra functionality.




1. Pick only one mod that relies on Eye Adaptation Complete Overhaul as a required dependency.

2. Uninstall the “original” full Eye Adaptation Complete Overhaul if you had it installed. Obviously, it would create a conflict 🙂

3. Check which of the Compatibility Dependency is required by the mod you chose

4. Download it from this mod page’s Main Files section in the FILES tab.

5. Install it alongside the mod of your choice.






This is where user section ends. If you’re not a mod author you don’t have to read anything below.





How to create a compatible mod yourself







This Modder’s Resource exists out of necessity.


Any mod that edits cp2077_master_env_nge_v002.env is automatically incompatible with each other, but my Eye Adaptation Complete Overhaul is much bigger than just the Master Env file.

I don’t want people shipping 50+ world-editing files that I spend hours and hours working on with their mod because it becomes incredibly complicated for me to keep my mod updated AND keep your mods updated.



Asking users to get my Compatibility Dependency file will be more convenient for mod authors and myself.


Firstly, I will try my best to keep this Compatibility Dependency up to date as soon as possible. However, if the game suddenly gets a new patch, please give me some time.

Eye Adaptation Complete Overhaul is quite a lot of work to update as there’s a LOT of world-editing files that need to be edited from scratch for any new Game Patch. This takes some time and might not happen the exact same day as WolvenKit tools update.


With that out of the way, creating a compatible mod is very simple.

I split the EACO mod into two parts:


a) Compatibility Dependency

– which is for the users of your mod to download as a requirement for Eye Adaptation Complete Overhaul-enabled variant of your mod. These are mostly world-editing files that would be necessary for many areas of the game to get my Eye Adaptation changes.


b) Modder’s Resource

– which is for the mod authors to download and use as a baseline which you edit your changes into. Include ALL of the Modder’s Resource files in your mod even if you don’t edit all of them. You do this instead of using the original Cyberpunk 2077 game files as your baseline, and build from there.


The following files will be included in the Modder’s Resource:


  • cp2077_master_env_nge_v002.env

  • 24h_weather_toxic_rain.envparam

  • 24h_weather_sandstorm.envparam

  • 24h_weather_rain_v2.envparam

  • 24h_weather_rain_q.envparam

  • 24h_weather_rain_halojump.envparam

  • 24h_weather_rain_dry.envparam

  • 24h_weather_rain.envparam

  • 24h_weather_pollution.envparam

  • 24h_weather_fog.envparam



Important note

– cp2077_master_env_nge_v002.env file will ONLY contain my Eye Adaptation (ExposureAreaSettings) changes.



Unlike the main variants of my Eye Adaptation mods, I will keep forced vanilla Sharpening and permanent vanilla Vignette untouched in the Modder’s Resource. Personally, I always prioritize disabling them but then I offer different variants with each ON/OFF combination.



I let you decide if you want to keep them turned on or disabled!



If you want to disable them and don’t know how, you simply have to edit cp2077_master_env_nge_v002.env you get from my Modder’s Resource and change the values to 0 while keeping the component’s main ‘enable’ field set to 1.

I export my .env file to JSON using WolvenKit so for me this is what it looks like:



Disabling the forced vanilla Sharpening yourself:








Disabling the permanent vanilla Vignette yourself:








Simplified steps of creating a variant of your mod that relies on and requires this Compatibility Dependency:


1. Download the appropriate Modder’s Resource variant from Optional Files. This is relevant because eventually, there might be more than just the Default variant of my Eye Adaptation Complete Overhaul. For example, I might add Kiroshi variant which would have increased Eye Adaptation Speed.

2. Take all the files from my Modder’s Resource and put them in your project. ALL of them. Even if you only plan to edit cp2077_master_env_nge_v002.env.

3. Edit the files you got from me and insert any changes that your mod consists of as if my Modder’s Resource were the original game files.

4. Align the JSON files within your WolvenKit project structure – the Modder’s Resource folder structure should help you do this. Then, import the JSON files. If you don’t know how, here’s a screenshot:

5. Build your mod and share it with users. Make sure to tell your users that the Compatibility Dependency from


THIS SPECIFIC MOD PAGE WE ARE ON RIGHT NOW



is required

and

tell them exactly which variant of Compatibility Dependency in Main Files they are supposed to get from me

.

For example, if you built your mod using:


"Modder's Resource - Baseline files for you to edit and include - Game v1.61 - DEFAULT Eye Adaptation Complete Overhaul"



Then you want to tell your users to get:


"Compatibility Dependency - Game v1.61 - DEFAULT Eye Adaptation Complete Overhaul - World Editing Component"



or just

“Game


v1.61 – DEFAULT EACO”

for short, because I know the file descriptions have a low limit of symbols.



Credits guide:

You don’t have to ask me for permission to use my Modder’s Resource or mention me in the credits of your mod,

as long as you require and inform the users to download Compatibility Dependency from me

. I think that’s fair. You don’t have to give me any percentage share of your Donation Points if you don’t want to and you don’t have to report to me when your mod releases or updates.

How you edit my Modder’s Resource is up to you as long as you keep intact the ExposureAreaSettings in each of the included files you get from me.

(Published on: 2023-08-23 02:01:00)

Related Game Mods

Attached Files:

File Name Download Count Download Button
Dependency- DEFAULT EACO - World Editing Component-6735-1-63-1692751972.zip 0 Download
Dependency- KIROSHI EACO - World Editing Component-6735-1-63-1692752060.zip 0 Download
Modder's Resource - DEFAULT - Diverse Weather-6735-1-63-1692752361.rar 0 Download
Modder's Resource - DEFAULT - Vanilla Weather-6735-1-63-1692752406.rar 0 Download
Modder's Resource - KIROSHI - Diverse Weather-6735-1-63-1692752450.rar 0 Download
Modder's Resource - KIROSHI - Vanilla Weather-6735-1-63-1692752470.rar 0 Download

Leave a Reply

Your email address will not be published. Required fields are marked *